"Required extension or module 'ldap' is not installed or loaded

Hi all,

I got a problem when trying to use the LDAP service in dreamfactory 2.0.
I got a message "Required extension or module ‘ldap’ is not installed or loaded, when i started to create the service.
Any method to solve it? Many thanks.

Yes, I recommend you install or enable the PHP LDAP extension. As covered in the documentation, in APT the package is php5-ldap, in Yum it’s php-ldap, and in Windows Bitnami instances it’s provided as php_ldap.dll.


Thanks for your reply. However, i still get the same error message. I am using Windows Bitnami and i think i have already enabled the PHP LDAP extension. It is located under the php/ext and the php.ini already included the php_ldap.dll.

Thanks for your reply

You can confirm whether or not the extension is working correctly by running in the command line:

C:\path\to\your\bitnami\directory\php\php.exe -m

See if ldap shows up in the list of installed modules.

So you ensured that php_ldap.dll is located in your extension_dir as configured in php.ini, that extension=php_ldap.dll is uncommented in php.ini, restarted the web server, and after that the php.exe -m | findstr ldap command still doesn’t report the extension as enabled?

(Link from Bitnami support.)

well… After i reinstall the whole DF2.0 and redo it again. It works finally. Thanks