Successful install steps on RHEL/CentOS 7

The instructions on GitHub for a RHEL install from GitHub sources were pretty good, but didn’t work well for me on RHEL/CentOS6, so I decided to try to use a new CentOS 7 install which I have experience administering over a Bitnami install which is a very fast way to get up and running, but makes maintenance difficult for me because it doesn’t fit with my other Linux servers.

I talked briefly to DreamFactory tech support who had some good suggestions for me and helped me get it working on CentOS 7. Maybe this will help others do the same.

I did a minimal CentOS 7 install and then did the following which worked just fine:

yum update
yum install epel-release
yum install curl httpd php php-common php-cli php-curl php-json php-mcrypt php-gd php-pear php-mysql mariadb-server git
systemctl enable mariadb
systemctl start mariadb
mysql_secure_installation (to set the root password)
mysql - u root -p  
    MariaDB [(none)]> create database dreamfactory;
    MariaDB [(none)]> grant all privileges on dreamfactory.* to 'dsp_user'@'localhost' identified by 'dsp_user';
    MariaDB [(none)]> flush privileges;
    MariaDB [(none)]> quit
setenforce 0
firewall-cmd --permanent --add-service=http
firewall-cmd --reload
systemctl enable httpd
mkdir -p /opt/dreamfactory/platform
chmod 777 /opt/dreamfactory/platform
git clone /opt/dreamfactory/platform
cd /opt/dreamfactory/platform

then edit /opt/dreamfactory/platform/scripts/ to change “WEB_USER=www-data” to “WEB_USER=apache” and run the script:

./scripts/ -cv
chown -R root:apache * .git* .dreamfactory*
chown -R :apache /opt/dreamfactory/platform/vendor/ ./composer.lock

then edit httpd.conf:

vi /etc/httpd/conf/httpd.conf

and change the following:

DocumentRoot "/opt/dreamfactory/platform/web"

<Directory "/opt/dreamfactory/platform/web">
    Options -Indexes +FollowSymLinks -MultiViews
    AllowOverride All
    Require all granted
    RewriteEngine on
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^.*$ /index.php [L]
        Allow from all

then edit /etc/php.ini to set the time zone manually (otherwise DreamFactory will bomb with a php error message that isn’t its fault)

date.timezone= America/New_York

and start httpd

systemctl start httpd

Then go to http://a.b.c.d/ and you should see your DreamFactory asking you to make an admin account.

Now to learn how Dreamfactory works…


Thans Alan. I just finished walking through your steps and successfully got a DSP up and running on CentOS 7. I will be using your notes update the wiki.

1 Like

Great. I’m glad it worked for someone else! I tried to go through my command history to make sure I didn’t miss anything, but there was a possibility that I forgot something.


Is there a problem with this line
git clone /opt/dreamfactory/platform

Could that be
git clone /opt/dreamfactory/platform

and 2ndly I don’t see this folder called scripts

then edit /opt/dreamfactory/platform/scripts/ to change “WEB_USER=www-data” to

Btw thanks for the steps…quite clear and concise


Dunno. I haven’t installed it in a while. I’m sorry to punt on this question, but maybe they changed the name of their repo in the meantime since I did it a year ago? Or maybe that’s a different repo that isn’t the same package that I installed.

Alright thanks :slight_smile: ~ M.M