DreamFactory on Centos Plesk with Virtual Host

How can DreamFactory be installed on a dedicated server running centos with plesk and having virtual host ,
If it can run on bitnami stack , sure there must be a way to do


Instructions to install on CentOS from source are at https://github.com/dreamfactorysoftware/dsp-core/wiki/Install-CentOS-RedHat

Not sure about plesk. Try it out.

hi ben finally battling for 48 hours i managed to get it right
so here is for those who wants to try your awesome product on plesk centos 64 bit


installed dreamfactory from GIT
run git command in webroot(httpdocs)
make db ‘dreamfactory’ with username ‘dsp_user’ and pwd ‘dsp_user’
(this is the default config)
using plesk make a databse in ‘website and domains’

adding remo to repo
using this

in the installation script change ‘www user’ to apache
composer.phar is in ‘/scripts’ directory whereas composer.json and composer.lock is in the parent directory of scripts

change document root using plesk website scripting and security
then put in ‘Directory’ directive in vhost apache conf

Options FollowSymLinks
AllowOverride All

in vhost file
these directories below if not exist needs to be made
sudo chmod 777 httpdocs/dsp-core/web/assets/ sudo chmod 777 httpdocs/dsp-core/log/
restart apache

hope that helps

1 Like

Awesome, thanks for posting how you got the install working with Plesk. Sorry it took so long, your post will help others a lot. Thanks :smile:

I have tried the same on CentOS 7 system. Mine is fresh DFS installation. I have followed the official documentation. When I try to launch the web console in browser, it shows the error “CDbConnection failed to open the DB connection”. What could be the problem? I disabled SELinux too. I have set all permissions as shown in the official wiki document. Pls help.

This means that MySQL is not being started up for some reason. Which ports do you have Apache and MySQL installed on? So, you installed using github… can you verify that apache service and mysql are running, please.


Thanks for the reply Mark. MySQL, and Apache services are running. I tried to install it using github on a fresh CentOS 7 minimal server. MySQL, and Apache uses the default ports. I didn’t change any ports. By the way, I am using mariadb(mysql replacement in centos 7). Thanks again.

Any way, I gave up the Github installation, and successfully installed it using Bitnami stack. It worked out of the box. I have posted the installation instructions in the following link.

Feel free to give any suggestions and corrections. Thanks for the Awesome product.