Update dreamfactory 2.04 to 2.1

How do I update to 2.1? I have a bitnami stack deployed on Google cloud? Can I just SSH into it a do a git pull or something?

Is 2.1 release? I only see 2.0.4-2. I am also experiencing the SMTP service issue

You can do a git pull, and then run the update. But, please make sure you run the artisan migrate command as well. See: http://wiki.dreamfactory.com/DreamFactory/Installation#Upgrade

By the way, my experience with the Google cloud images is that you need to run the update process using sudo.

I tried the upgrade process as described on the wiki but now I’ve messed up my system. Its getting errors on the composer install:

The .git directory is missing from /opt/bitnami/apps/dreamfactory/htdocs/vendor/symfony/http-foundation, see h
ttps://getcomposer.org/commit-deps for more information

And it also recommends running an update, which results in the error:

The .git directory is missing from /opt/bitnami/apps/dreamfactory/htdocs/vendor/symfony/var-dumper, see https:
//getcomposer.org/commit-deps for more information

So now I’m stuck. I did a snapshot on google cloud thinking this was the way to do a backup, and now I cant figure out how to use it to backup to before I tried this…

I’ve seen this issue before. Delete the vendor directory and restart the process.

Also, in the upgrade instructions, where it tells you to copy the htdocs folder, that is your backup. You can restore the htdocs.old folder back to htdocs.

1 Like

phew, yes, I figured out the deleteing the whole vendor directory thing. I am back up.


I ran the upgrade but it still reports version 2.0.4 in the web console. There were no errors running the upgrade. How can I confirm it actually happened?

That was my initial experience too. But it will show up as 2.1 when you complete the process. Check out that link, http://wiki.dreamfactory.com/DreamFactory/Installation#Upgrade. You will need to delete everything in the vendors folder and then do a ‘composer update’.

Thx for the info on deleting the vendor dir. Worked.

Yeah, it looks like on a couple of the builds Bitnami deleted some needed git files in those vendor files. Deleting the Vendor directory will work.
Make sure you backed up the htdocs folder as recommended in the documentation!

1 Like