Can't read swagger JSON from

I just installed Dreamfactory 2.0.4 on my Mac OSX 10.11.3. I was able to successfully connect to our SQL database and i can see the records.

However, I can’t seem to get the Swagger docs to work. When I click on the API Docs tab from the admin console, i get the following error:

Can’t read swagger JSON from

There aren’t any obvious problems in the
apps/dreamfactory/htdocs/storage/logs/dreamfactory.log file

Any help would be greatly appreciated.

Thanks in advance.

On a whim, i tried Google Chrome and it worked.

Retried again with Safari and it gets the same error.

Hopefully this will help someone else.

@schwame Can you try flushing the browser cache in Safari and going to the config tab in DF and flushing the system-cache? Do a refresh of the browser page and see if the Swagger docs are available?

@mattschaer - Before I had restarted everything, I did clear my safari cache. That alone did not solve the problem. When I restarted dreamfactory a few hours later, it did work. I assume it was the combination of the dreamfactory restart - which I assume flushed the system-cache, and the clearing of the safari cache.

Thanks again

Same error in a fresh install

{“schemaValidationMessages”:[{“level”:“error”,“message”:“Can’t read from file”}]}

rebootand fush cache

Any idea

@jmontes - Mine was on a fresh install also. I emptied my safari caches. Shut down DreamFactory entirely… and then (for me a few hours later), I restarted DF and everything worked.

That being said, Chrome worked for me the entire time.

Sometimes using vs. localhost will cause this. Usually resolved by flushing system and browser cache.

flushing system and cache dont solve anything

I was trying with a fresh instalation and the same error

{“schemaValidationMessages”:[{“level”:“error”,“message”:“Can’t read from file”}]}

this “explorer” tool in the header , its normal ?

my instalation is a new ofical debian jessie in AWS

my instruccions of instalation below:

apt-get update
apt-get install aptitude
apt-get install vim git curl php5 php5-common php5-cli php5-curl php5-json php5-mcrypt php5-gd
apt-get install php5-mysql mysql-server mysql-client php5-sqlite

php5enmod mcrypt
cd /usr/src
curl -sS | sudo php – --install-dir=/usr/local/bin --filename=composer
mkdir /opt/dreamfactory

cd /opt/dreamfactory
git clone /opt/dreamfactory
composer config -g 04ccxxxxxxxxxxxxxxxxxxxxxxxxxxxx (my token)
composer install --no-dev
chown -R www-data:www-data storage/ bootstrap/cache/
chmod -R 2775 storage/ bootstrap/cache/
php artisan dreamfactory:setup
chown -R www-data:www-data storage/ bootstrap/cache/
chmod -R 2775 storage/ bootstrap/cache/
mysql -u root -p
create database dreamfactory;
grant all privileges on dreamfactory.* to ‘df_admin’@’%’ identified by ‘df_admin’;

a2enmod rewrite
vim /etc/apache2/sites-available/000-default.conf
DocumentRoot /opt/dreamfactory/public
<Directory /opt/dreamfactory/public>
Options -Indexes +FollowSymLinks -MultiViews
AllowOverride All
AllowOverride None
Require all granted
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^.*$ /index.php [L]

        Allow from all

service apache2 restart

any ideas


I am getting the same error on a bitnami fresh install.

Admin Application Version: 2.1.3

DreamFactory Version: 2.1.0

I originally installed the 2.0 bitnami version and follow the upgrade instructions, but I get the same result as the updated 2.1 bitnami dreamfactory install.

Let me know if there is any log information that would be helpful in troubleshooting.

Same here. Fresh Bitnami 2.1 install.


I install v8js in php-cli and the error disaper

Hi jmontes,

I tried installing both v8js and php-cli and I am still getting the error.

Are you using bitnami?
Did you get the error on upgrade or fresh install?
Were there any special steps for installing v8js and php-cli?


debian jessie
git install, not bitmani

first has the error, then install v8js
the error disappeared

I am getting the same problem on a microsoft azure image - > DreamFactory 2.1.0-4-r05 (Ubuntu 14.04) . It’s a fresh install. What can I do ?