Swagger definition error - Could not resolve reference

Hi,

I am new in Dream Factory community and I juste install Bitnami windows version locally in order to try it.
I am interessed into creating Remote Services API and I try to put a swagger definition getting the Swagger example from https://editor.swagger.io/ because my swagger definition has the same error.

Here the errors :

I saw that there is some problem with Swagger editor, bet before I used WSO2 with references defined into the swagger definition without obtaing this error.

Can someone tell me what can be the problem ?

Thanks a lot

This looks like you tried to use a Swagger 2 definition. In DreamFactory 2.10 we changed to version 3 of the Open API Spec (formerly called Swagger spec,) as notated here: http://wiki.dreamfactory.com/DreamFactory/Release_Notes#Version_2.10.0_.28Released_November_6.2C_2017.29

1 Like

Thanks, this was very helpful for me !

Juste I would ask you if the Swagger version used in dream factory support the references for parameters.
I create a parameter refereneces for the header of my web services and I got the following erroro:

Resolver error at paths./list.post.parameters.0.$ref
Could not resolve reference because of: Could not resolve pointer: /components/parameters/apiKeyParam does not exist in document

We are working on incorporating that feature in our next release. When we made the switch to 3.0, all of the functionality wasn’t included at the time, so we are looking to get our support for the swagger-client up to date.