Connect to PostgreSQL Database


I am hoping someone here can help me. I need auto-generate APIs to my PostgreSQL database. the database is hosted on my hosting provider shared server. I have to connect to it using SSH tunnels. Direct SSH access is not allowed.

I used the Bitnami Dreamfactory VM and got the instance up and running. On the terminal, I established an SSH tunnel connection to my hosting server. On the dreamfactory web interface, I created the Service to PostgreSQL but when I test on API Docs (Get /_Table), I get the following error:

“error”: {
“code”: “42P01”,
“message”: “SQLSTATE[42P01]: Undefined table: 7 ERROR: relation “pg_matviews” does not exist\nLINE 11: FROM pg_matviews\n ^ (SQL: SELECT all_views.table_name, all_views.table_schema\n FROM (\n SELECT table_name AS table_name,\n table_schema AS table_schema,\n table_type AS table_type\n FROM information_schema.tables\n UNION ALL\n SELECT matviewname AS table_name,\n schemaname AS table_schema,\n ‘VIEW’ AS table_type\n FROM pg_matviews\n ) AS all_views\n WHERE all_views.table_type = ‘VIEW’ AND table_schema = ‘public’)”

I have no wider why it is looking in the views table.

So either I am doing something wrong or I have not correctly connected to my postgreql database or I am connected buy but trying yo access system tables.

The strange this is when I try Get /_table/{table_name} and enter one of the tables I created I get the same error about pg_matviews.

Can someone help?

1 Like

Found a solution to this.
I was running PostgreSQL13 and decided to try with a PostgreSQL version 12 install. The connection worked. Not sure why, but it looks like things work without a hitch in 12 but not with 13. Would be interesting to hear from the developers any input on this.