Postgres - connecting to a specific schema

I’m able to create an sql service to my postgres database using:


And query the tables in the default schema. However I need to access a particular schema.

I’ve tried:

Neither work.

I’ve also tried prepending the schema name to the table name on rest queries using roadlayers.testdata as the table name.

What am I missing?

Just giving you a quick follow-up. Working on this for you right now. Thanks,

Quickly, are you able to simply make the particular schema you want to use for that table the default schema through postgres?

Then proceed to connect to that particular DBname/table and the default schema will be updated when connected.


I’m not sure I understand. Are you saying I need to move all the tables that I want to use with Dreamfactory into the “public” schema?

If Dreamfactory supported views I suppose this would be workable as I could just create a view in the public schema. But cramming multiple schemas into public isn’t going to work for us.

Sorry for the delay in response. We have a new release coming out in the next couple of days that will address this issue and you’ll be able to connect to a specific schema. It is all still being tested, but I wanted to at least give you an update as to what to expect in the new release.