Getting a Server returned error code 500 from a fresh installation

Its been installed using the Bitnami installer with port 9000 assigned as the default port but I am getting this error every time I open the webpage. The Launchpad appears, runs through the initial configuration items but then it stops at this error code.

Anyone got any suggestions?

Its installed on Windows Server 2008 R2. I’ve turned off the hardened security in IT to check that this wasnt the issue.


Have you installed a DSP on this machine before, or is this the first DSP that you’ve tried to put on this machine? Are you installing the dreamfactory module on top of the wampstack? or have you downloaded the “bundled” package?

I have access to the same OS, so will try to replicate your issue.


When you installed, did you install as an administrator? This will occasionally be an issue when installing on Windows… Either way, I was able to successfully install on a 2008 R2 machine using port 9000…

Did you leave your MySQL port as default?


  • Mark

Hi Mark,

Thank you for coming back to me. To answer, this is the first DSP installed and I have used the bundled Bitnami installer with the WAMP stack, I am sure that I have installed as an administrator, but I cant remember which port I set MySQL to. I could uninstall and check this.

I’ve tried it on 2 machines and got the same error now. One Win 7 and one Server 2008 R2. Ill try downloading the installer again and check the settings that I use during the installation.

Best Regards,


I’ve tried re-installing but getting the same every time. I’ve been forced before to change ports, but now have killed off the other services that were blocking port 80 (SQL Reporting Services) and 443 (Teamviewer service). So I can now install with defaults and I am trying with the WAMP stack separately first from Bitnami and then will install the dreamfactory module.

Fingers crossed.

Still getting the same error every time.

Ok, I had been installing the service into a custom folder rather than c:\Bitnami, but this seems to have been the root of the issue.

It is now up and running so a note to all new users, use all of the defaults.

Using the default port values was your solution?

No, I had tried installing with default ports that but was still getting the same error. It seems it was all down to wanting to install the software in a different folder which is odd.

and, you definitely installed as administrator throughout? I guess the important thing is that you’re up and running!