Upgrade from 1.6.3 to 1.6.10


#1

I had put down my dreamfactory project for a few weeks as i eagerly awaited changes that would allow stored procedures. Today i checked to see if there was an upgrade to my instance (running on AWS) and in fact there is:

Database Version: 1.5.0

DreamFactory Services Platform Version: 1.6.3

DSP Version 1.6.10 is available!

but when i click upgrade i get:

Well, this is embarrassing…
The server has experienced a fatal error. Our administrators will automatically be notified. However, if you would like to report additional information regarding this particular error, please open a case on our bug tracker.

Error 500
Internal Server Error

Error Details
copy(/opt/bitnami/apps/dreamfactory/htdocs/.dreamfactory.php): failed to open stream: Permission denied


#2

Hey Erik,

There’s a known issue and workaround with the AWS upgrade. See this post and let us know if that solves your problem. Upgrading from 1.5.9 to 1.6.10 on AWS Bitnami. Sorry about that, the upgrade issue on AWS will be fixed in the next release.

Also, stored procedures support did not make it into 1.6.10. It’s being implemented and tested now by the team. It’ll be live in a couple weeks when we push out the next release.