Creation of SOAP Service breaks API Docs


I have been trying to add a SOAP Service as described in this post but whenever I create the service and go to the API docs to test it, the Docs tab presents a dump of raw HTML code and Stylesheet with the line <h1>Whoops, looks like something went wrong.</h1> somewhere near the end.

When I delete the service, everything goes back to normal and the API Docs are accessible again. Have tried this with several different WSDLs but get the same result. Am running DreamFactory Version: 2.1.0 and Admin Application Version: 2.1.3. on Windows 10.

How can I figure out what is going on and how can I correct it?

I’m having the exact same issue. Have you figured anything out on this?

Sorry, still can’t figure it out. Tried everything, might just have to upgrade to 2.1.1 and see if that helps.

I’m curious to see how or if that works. I’m really wanting to use this feature.

@techspecguy are you also on Windows Bitnami stack like @Kapische? I have isolated this to Windows environments.

@techspecguy @Kapische So it appears after testing the SOAP client is commented out on the Windows installs. You’ll need to edit the ‘php.ini’ file located in the PHP folder in your installation path. Example: C:\Bitnami\dreamfactory-2.1.1-0\php Look for line 914: ‘;extension=php_soap.dll’ and remove the semicolon preceding the extension. Save the changes and restart the Bitnami stack, clear the system cache and test the service again from API docs.

Thank you so much @mattschaer, this has resolved the issue for me.