Update a Windows Bitmani instance, from 1.8.0 to 1.9.0, using the Bitmani installer

Hi guys,

My intention was to update the Bitmani 1.8.0 instance to 1.9.0. This is installed on a Windows 2008 EC2 server.
I downloaded and started the installer, but that seems to create a new instance instead of updating the previous one.

The official page is quite clear, but there is no information related to the Windows update process. My good friend, Google, says nothing about it, so is there any chance that you could give me some additional information on how to use the Bitmani 1.9.0 installer to update my 1.8.0 instance.

Any help would be greatly appreciated.

Bitnami installers do not offer upgrade capability. You should either upgrade via GitHub by adapting the upgrade guide to your Windows environment, or by installing 1.9.0 beside your existing instance and then copying over the appropriate content (also outlined in the upgrade guide).

Thank you for the reply Jeffrey.
Just to give you a quick feedback: I have tried both strategies, but in both cases I had errors.

At this point I prefer to postpone the upgrade until I finish the development.
Thanks for the support


I’m in the same boat as Gabriel. I have a DSP under 1.8.0 Windows Bitnami. Would like to go to 1.9.0 since I want to take advantage of fixes in the email area. I can’t (apparently) do this via upgrade?

So If I understand things correctly, my best option is to install 1.9.0 side by side (different ports of course!) and then dig into the files / database and grab the existing data after resetting up the DSP manually?

I tried clicking the links above - but they seemed to take me to a Linux/Mac guide that didn’t seem to have much to do with Windows/Bitnami?

I just want to make sure that that is the right course of action before heading down that road. Windows vs Linux vs XYZ issues aside - is there a preferred setup for DF that would be more advantageous?

You should be able to run a Composer update from Windows, just as the instructions I linked do in a Linux environment. No errors have been posted, so I can’t be more specific until I know what problem you’re seeing.